issue with internet connections

Incident Report for After Dark Graphixs

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 08, 2022 - 19:24 UTC
This incident affects: Public Website, Payments, CRM, and Phone, Text And Email.